WordPress upgrade (2)

I have WordPress upgraded to 2.8.3 without problems. Just had to be careful about Gengo activation and the permalink refresh (see previous post). Some people have reported that Gengo wouldn’t be compatible with WordPress 2.8. With the patch that I mentioned in my previous post it does work however. But I must admit that I have been hacking in my copy of Gengo in the past so it could be that the official version still has problems that I don’t have any more.

Anyway, I think the Gengo situation is just too fragile. Therefore I am now investigating the WPML plugin. More about that in a later posting.

Update August 22, 2009: Although reading the site now seems to work with my patch to Gengo, I experience problems on the Admin page. Some of the popups don’t work e.g. in the `Edit a post’ page.